Delay in data transfer

Incident Report for Level AI Status

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 17:13 UTC

Monitoring

Issue has been resolved and data transfer timelines are back to normal.
Posted Jun 23, 2026 - 15:38 UTC

Investigating

Our third-party data transfer provider is experiencing an issue which is impacting a handful of customers. Until this is resolved these customers will see a delay in data available in Level AI analytics and downstream features (i.e. VOC, AI Workers, and exports which rely on this data).
Posted Jun 23, 2026 - 13:16 UTC
This incident affected: Analytics, Voice of Customer, and AI Workers.