Delay in data transfer for analytics & exports

Incident Report for Level AI Status

Resolved

Incident has been resolved and data pipelines (along with downstream features) are back to normal ingestion timelines.
Posted Jun 16, 2026 - 13:20 UTC

Monitoring

A fix has been implemented; data pipelines for affected customers may take up to 4 hours to catch up and return to normal processing times. Monitoring progress and pipeline recovery speed.
Posted Jun 15, 2026 - 18:32 UTC

Update

We are continuing to investigate this issue.
Posted Jun 15, 2026 - 14:36 UTC

Investigating

Our third-party data transfer provider is experiencing an issue which is impacting a handful of customers. Until this is resolved these customers will see a delay in data available in Level AI analytics and downstream features (i.e. VOC, AI Workers, and exports which rely on this data).
Posted Jun 15, 2026 - 14:34 UTC
This incident affected: Analytics, Voice of Customer, and AI Workers.