Delay in data transfer for analytics & exports

Incident Report for Level AI Status

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 06:05 UTC

Investigating

Our third-party data transfer provider is experiencing an outage which is impacting a a handful of customers. Until this is resolved these customers will see a delay in data available in Level AI analytics & exports.
Posted Apr 22, 2026 - 20:53 UTC
This incident affected: Analytics.