Platform Performance Degradation and Login Issues

Incident Report for Level AI Status

Resolved

All incidents have been mitigated. All logins failures and platform slowness incidents have been fully resolved.
Posted Apr 16, 2026 - 16:05 UTC

Update

We're again observing some login failures. We're actively working on resolving the incident and will provide updates as we have more information.
Posted Apr 16, 2026 - 15:47 UTC

Monitoring

Login incidents have been resolved. We're monitoring slow load times and will provide updates as we have more information.
Posted Apr 16, 2026 - 15:20 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 16, 2026 - 15:16 UTC

Investigating

We are currently experiencing login failures, along with elevated load times across the platform. Our engineering team has identified the issue and is actively working on a resolution. We will provide updates as we have more information.

Impact: Some users may be unable to log in. Users who are logged in may experience slower than usual page loads and response times.
Posted Apr 16, 2026 - 14:57 UTC
This incident affected: Login.